Alex's Ben Kenobi Lightsaber Hilt WIP

Moderator: DCO

User avatar
alex_slas7
Base Executive Officer, Scottish Events Coordinator
Posts: 704
Joined: Wed Jan 03, 2018 1:10 pm
Name: Alex Dick
Location: Glasgow, Scotland
2020 Troops:: 0
Total Troops: 63
501st Number: 13128
Rebel Legion.com User: alex_slas7

Alex's Ben Kenobi Lightsaber Hilt WIP

Post by alex_slas7 » Wed Nov 06, 2019 10:04 am

I'll add the Pics when I get them hosted

M'Kay, at the suggestion of the WIP overlord - I've decided to chronical the building of my lightsaber.
Firstly, as one of my costumes is Obi-wan - I decided to go with one of his sabers.

Design ideas/considerations

Hilt Body
I've got a ROTS saber already and another ROTS on the way - I've decided to try the ANH version.
It’s very much to be a display piece and not for duelling. Got this second hand so hopefully it'll look ok.

LEDS
I've wired a few single LEDs before and the one I'm getting professionally made is a neopixel, so I decided to go for a Tri-Cree version.
The Tri-Cree can be bought in various configurations, generally RBG, but it would drive me nuts to see an Obi Saber with anything other than a blue blade - so Blue, Blue, White is the plan.

Sound
Yes please! There are a variety of options for sound but another member has been playing with the Proffieboard and that is quite a high function board at a decent cost. It’s quite complicated but we shall see. This will allow for multiple sound fonts, force sounds, (music player!) and colour change (which won’t be necessary).

I, controversially, decided not to install a recharge port - I've went with a kill switch as I'd like to be able to swap out the batteries on the fly - [edit] I know now that this was a mistake, but C'est la Vie.
So that’s my vague plan...
Image

I needed to decide on the resistors used to stop the LEDs going nuts, getting hot and draining the battery too quickly.
I was going for a BBW Tri-Cree which had the following specs.

2 x Blue LED – 3.4 Volts at 1000ma
1 x White LED – 3.15 Volts at 1000ma

Blue
(3.7-3.4)/1 = 0.3 Ohms
(3.7-3.4)*1=0.3W

White
(3.7-3.15)/1 = 0.55 Ohms
(3.7-3.15) *1 = 0.55W

So I ordered the resistors from RS.
The saber armoury provided a 2W VECO speaker, the 3D print files for the 89Sabers OWK4 chassis, Tricree (BBW), optic, heatsink, Optic holder, battery holder and kill switch .
There is a hiccup with the heatsink but that’s for later in the build...

To the building...
The OWK4 comes apart into handy sections and with the chassis printed - I soldered wires onto the battery holder

Image

bridged the LED pads on the star

Image

Image

I then wired the kill-switch,
The Resistors didn’t arrive so that had to wait. The Kill switch was a three-pole switch (off, on [position 1], on [position2]) but I only needed it as an on-off so I only needed to solder one leg.

By unrusting my solder skills on the other parts - i started on the (TINY) Proffieboard, as this was only an in hilt LED setup - I didn’t have to use most of the connections on the board.
Image


I applied solder to each point on the board, tinned the tiny wires and melted the solder enough to push the wire through the holes on the board. I used my DMM to ensure good connection on all joints.

Thankfully - I did most of this at work - so I had a Variable DC source to check the LEDs. It looks messy as hell, but seems solid enough.



With the speakers, battery, LEDs and board largely soldered - then came the fun part of threading everything through the chassis and making connection. As I still had no resistors, I left them out and would add them in later.

Image

Now at the stage of having everything, mostly, installed - I noticed that the LED housing was very large inside the emitter section - it was so high that I couldn’t get a blade in enough to be secure.

[PIC]

Not happy…
Some googling informed me that most people don't use the heatsink inside an obi-wan hilt as the emitter acts as a heatsink and that would give me approx 3.5/4.0mm extra. Not a huge amount but hopefully enough to secure a blade.

With everything inside the chassis and the chassis (mostly) installed inside the hilt - I wired the switch and secured it to the hilt.
Upon adding a battery, and toggling the kill-switch - i heard that the speaker worked! However it was screaming "SD CARD NOT FOUND" "FONT NOT FOUND".
So once I remembered to add the SD card - I only got "FONT NOT FOUND" - which is progress.

Programming

Right, So with the Board and Hilt Largely installed - it’s time to try my hand at programming....

I wont got into massive amounts of detail, but the steps are as follows
1. Download Arduino Program, SD card settings/example font folder and ProffieOS folders
2. Connect board with MicroUSB cable to PC
3. Allow Windows to install standard driver
4. Use Zabit to rewrite Windows assigned driver with the Proffieboard driver
5. Create a saber profile and config file. (I can detail this later if people would like)
a. ALL saber properties – fonts, LEDS, no of Blades, Resistor sizes etc are written into the config file so once that is correct – its looking promising.
6. Run the Arduino Program with the ProffieOS code
7. Edit the ProffieOS program to match the name of the config file.
8. Compile the program
9. Upload to the proffie board.
10. Add font folders to the SD card.

Et Voila!
It was doing stuff!

So with that working – I went to put the saber together – I received the resistors so I soldered them in line [MAKE SURE THE BATTERY IS REMOVED AND THE SD IS NOT IN THE BOARD]
Everything is together and… I find the switches don’t fit– the thread on the hilt is shot. So that’s a fix I’ll look at when I find my taps. But it works! So im pretty darn happy.
Alex D - alex_slas7
Elstree Base Executive officer (BXO)
Scottish Events Coordinator

Cleared Costumes
Jedi Knight - Xelan Kidd,
Obi-wan Kenobi - ROTS,
OT X-Wing Pilot - Lexan 'Specs' Kidd
ESB Imperial Crewman & TIE Reserve - UKG

Fraz
Posts: 138
Joined: Thu Jan 17, 2019 12:03 pm
Name: Fraser Stevenson
2020 Troops:: 3
Total Troops: 10

Re: Alex's Ben Kenobi Lightsaber Hilt WIP

Post by Fraz » Mon Nov 11, 2019 9:53 am

Nice. What size taps you need?

User avatar
KennyC
Assistant Detachment CO
Posts: 43
Joined: Wed Jan 03, 2018 4:05 pm
Name: Kenny Crawford
Location: Oban
2020 Troops:: 0
Total Troops: 7

Re: Alex's Ben Kenobi Lightsaber Hilt WIP

Post by KennyC » Thu Dec 12, 2019 5:26 pm

This is great, I have absolutely no idea what any of it means, but it's still great :grin:

User avatar
Andrewsboy
Posts: 77
Joined: Wed Jan 03, 2018 1:25 pm
Name: Paul Andrews
Location: Yeovil
2020 Troops:: 0
Total Troops: 14
501st Number: 4156

Re: Alex's Ben Kenobi Lightsaber Hilt WIP

Post by Andrewsboy » Thu Dec 12, 2019 9:33 pm

I take my hat off to you sir.
I have got the same hilt for Christmas and plan to kit it out in the new year.
I’m watching this thread with interest


Sent from my iPhone using Tapatalk
Image

User avatar
alex_slas7
Base Executive Officer, Scottish Events Coordinator
Posts: 704
Joined: Wed Jan 03, 2018 1:10 pm
Name: Alex Dick
Location: Glasgow, Scotland
2020 Troops:: 0
Total Troops: 63
501st Number: 13128
Rebel Legion.com User: alex_slas7

Re: Alex's Ben Kenobi Lightsaber Hilt WIP

Post by alex_slas7 » Mon Dec 16, 2019 10:30 am

Sooooooooo............ Update time.

a couple of issues

Firstly, using the emitter as a heatsink works, but it can only take so long being powered before the heat becomes an issue - I ended up frying part of the LED (after installing my resistors) - so I ordered a new one and then had to come up with a solution to incorporate a heatsink.

I had an old 7/8" heatsink and LED holder - So i had to dremel the edges of the LED to allow it to fit in the holder but that allowed it to have a mounted heatsink and ample thermal paste.

So this presented a further issue - now I couldnt get a blade to fit....

So the dremel came back out - I cut back the glued section on one of my 1" Diameter blades, then removed the inner diffusive film (carefully) and cut approx 1" off the end of the film.

With the film Removed, I used the sanding drum to sand down the centre of the tube to allow the 7/8th LED holder to fit snugly inside the tube - this took some trial and error but I got there,.

This is messy process so I then had to clean out the inside of the tube to prevent the Light showing up the crap, then added the film again. Sorted!
Alex D - alex_slas7
Elstree Base Executive officer (BXO)
Scottish Events Coordinator

Cleared Costumes
Jedi Knight - Xelan Kidd,
Obi-wan Kenobi - ROTS,
OT X-Wing Pilot - Lexan 'Specs' Kidd
ESB Imperial Crewman & TIE Reserve - UKG

User avatar
alex_slas7
Base Executive Officer, Scottish Events Coordinator
Posts: 704
Joined: Wed Jan 03, 2018 1:10 pm
Name: Alex Dick
Location: Glasgow, Scotland
2020 Troops:: 0
Total Troops: 63
501st Number: 13128
Rebel Legion.com User: alex_slas7

Re: Alex's Ben Kenobi Lightsaber Hilt WIP

Post by alex_slas7 » Mon Dec 16, 2019 10:36 am

One quick note,

I omitted adding a recharge port - I would def advocate putting one in.

If i want to charge the battery -
  • I have to remove the bottom two sections
  • Unscrew the buttons,
  • take off the glaflex section,
  • unscrew the switch,
  • Slide out the chassis
  • then the remove the battery.
At least If id added a recharge port then I would only need to do that when changing a battery, not if i need to charge it.... Lesson learned.
Alex D - alex_slas7
Elstree Base Executive officer (BXO)
Scottish Events Coordinator

Cleared Costumes
Jedi Knight - Xelan Kidd,
Obi-wan Kenobi - ROTS,
OT X-Wing Pilot - Lexan 'Specs' Kidd
ESB Imperial Crewman & TIE Reserve - UKG

Post Reply

Return to “Jedi Work in Progress Threads”